commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jodastephen <...@git.apache.org>
Subject [GitHub] commons-lang issue #299: Add module-info for Java 9
Date Mon, 23 Oct 2017 15:35:33 GMT
Github user jodastephen commented on the issue:

    https://github.com/apache/commons-lang/pull/299
  
    @michaelsavich , this PR does not create a full dependency on `java.desktop`. The dependency
is expressed as `requires static`, which means that it will not be pulled in by default. Users
that want to use the two broken classes on Java 9 in module mode (a very small percentage
of commons-lang users) will need to manually include the `java.desktop` dependency. As such,
there is no urgency to get `AbstractCircuitBreaker` removed.


---

Mime
View raw message