commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ravi Kharatmal (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DIGESTER-184) upgrade common-beanutils to 1.9.2 to resolve security vulnerability
Date Fri, 25 Aug 2017 19:23:02 GMT

    [ https://issues.apache.org/jira/browse/DIGESTER-184?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16142060#comment-16142060
] 

Ravi Kharatmal commented on DIGESTER-184:
-----------------------------------------

Even the most latest version of commons-digester3 i.e. 3.2 is using common-beanutils 1.8.3.


<!-- https://mvnrepository.com/artifact/org.apache.commons/commons-digester3 -->
<dependency>
    <groupId>org.apache.commons</groupId>
    <artifactId>commons-digester3</artifactId>
    <version>3.2</version>
</dependency>

Compile Dependencies (3)
cglib » cglib 2.2.2
{color:red}*commons-beanutils » commons-beanutils 1.8.3*{color}
commons-logging » commons-logging 1.1.1

Questions:
1) Does that mean there is no version at all available for digester library with this security
vulnerability fixed? Please correct me if I am mistaken. 
2) Is there any external configuration that we can provide to fix this vulnerability in available
digester versions?
3) Is there any other library suggested by apache instead of commons-digester or commons-digester3
which isn't vulnerable?

> upgrade common-beanutils to 1.9.2 to resolve security vulnerability
> -------------------------------------------------------------------
>
>                 Key: DIGESTER-184
>                 URL: https://issues.apache.org/jira/browse/DIGESTER-184
>             Project: Commons Digester
>          Issue Type: Bug
>    Affects Versions: 2.1, 3.2
>            Reporter: Santosh P
>            Priority: Minor
>
> Hello,
> We have been reported for security vulnerable library common-beanutils-1.8.3. common-digester
is dependent on this library and which is downloaded to application WEB-INF/lib while packaging.
> Clould you please upgrade to latest release 1.9.2 of common-beanutils and make use of
'SuppressPropertiesBeanIntrospector'.
> More details can be found here:
> https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-0114
> http://openwall.com/lists/oss-security/2014/06/15/10
> http://commons.apache.org/proper/commons-beanutils/javadocs/v1.9.2/RELEASE-NOTES.txt
> https://issues.apache.org/jira/browse/BEANUTILS-463



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message