commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bruno P. Kinoshita (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (NUMBERS-23) mvn site won't compile due to javascript error
Date Fri, 21 Apr 2017 23:48:04 GMT

    [ https://issues.apache.org/jira/browse/NUMBERS-23?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15979611#comment-15979611
] 

Bruno P. Kinoshita edited comment on NUMBERS-23 at 4/21/17 11:48 PM:
---------------------------------------------------------------------

Successfully reproduced the issue in my local environment:

{noformat}
Apache Maven 3.3.9 (bb52d8502b132ec0a5a3f4c09453c07478323dc5; 2015-11-11T05:41:47+13:00)
Maven home: /opt/maven
Java version: 1.8.0_121, vendor: Oracle Corporation
Java home: /usr/lib/jvm/java-8-oracle/jre
Default locale: en_US, platform encoding: UTF-8
OS name: "linux", version: "4.4.0-72-generic", arch: "amd64", family: "unix"
{noformat}

Fixed by adding the --allow-script-in-comments. In the top level module's pom.xml we were
using JavaScript, which is not enabled by default (see report about [undocumented change in
the API|http://mail.openjdk.java.net/pipermail/javadoc-dev/2017-January/000281.html]).

The mvn site command still failed due to invalid HTML format (we can't wrap UL tags with P
tags... see [this SO answer for complete explanation|http://stackoverflow.com/a/5681796]).
Fixed in master branch.

Also noticed that the project Logo was missing, so fixed the URL as well, and added the changes.xml
entry.

Cheers
Bruno


was (Author: kinow):
Successfully reproduced the issue in my local environment:

{noformat}
Apache Maven 3.3.9 (bb52d8502b132ec0a5a3f4c09453c07478323dc5; 2015-11-11T05:41:47+13:00)
Maven home: /opt/maven
Java version: 1.8.0_121, vendor: Oracle Corporation
Java home: /usr/lib/jvm/java-8-oracle/jre
Default locale: en_US, platform encoding: UTF-8
OS name: "linux", version: "4.4.0-72-generic", arch: "amd64", family: "unix"
{noformat}

Fixed by adding the --allow-script-in-comments. In the top level module's pom.xml we were
using JavaScript, which is not enabled by default (see report about [undocumented change in
the API|http://mail.openjdk.java.net/pipermail/javadoc-dev/2017-January/000281.html]).

The mvn site command still failed due to invalid HTML format (we can't wrap UL tags with P
tags... see [this SO answer for complete explanation|http://stackoverflow.com/a/5681796]).

Also noticed that the project Logo was missing, so fixed the URL as well, and added the changes.xml
entry.

Cheers
Bruno

> mvn site won't compile due to javascript error
> ----------------------------------------------
>
>                 Key: NUMBERS-23
>                 URL: https://issues.apache.org/jira/browse/NUMBERS-23
>             Project: Commons Numbers
>          Issue Type: Bug
>            Reporter: Eric Barnhill
>            Assignee: Bruno P. Kinoshita
>
> mvn site fails with the following error. This error appears to apply to either the entire
commons-numbers site or the commons-numbers-complex subsite
> Exit code: 1 - javadoc: error - Argument for -header contains JavaScript.
> Use --allow-script-in-comments to allow use of JavaScript.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message