commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From martin-tarjanyi <>
Subject [GitHub] commons-lang issue #221: Add IsAllEmpty and isAllBlank methods
Date Sat, 10 Dec 2016 17:02:55 GMT
Github user martin-tarjanyi commented on the issue:
    So if this method is not added to the codebase but I would like to have this functionality
in my client code, then I should call ``!isAnyNotEmpty(...)``. It would be very difficult
to read. That's why I thought these methods would be useful. 
    However, if I should choose between ``isAllEmpty`` and ``isAnyNotEmpty`` to be in StringUtils,
I would support ``isAllEmpty`` because the negated version ``!isAllEmpty`` is more readable
in a client code.
    What do you think?

If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at or file a JIRA ticket
with INFRA.

View raw message