commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bruno P. Kinoshita (JIRA)" <j...@apache.org>
Subject [jira] [Created] (WEAVER-17) Missing HelpMojo when trying to run mvn clean org.apache.commons:commons-weaver-maven-plugin:help
Date Sat, 19 Nov 2016 06:55:58 GMT
Bruno P. Kinoshita created WEAVER-17:
----------------------------------------

             Summary: Missing HelpMojo when trying to run mvn clean org.apache.commons:commons-weaver-maven-plugin:help
                 Key: WEAVER-17
                 URL: https://issues.apache.org/jira/browse/WEAVER-17
             Project: Commons Weaver
          Issue Type: Bug
          Components: maven-plugin
            Reporter: Bruno P. Kinoshita
            Priority: Minor


This week while playing with weaver, trying to write a weaver for a Spring project, I tried
to see the help with the following command:

{noformat}
mvn clean org.apache.commons:commons-weaver-maven-plugin:help
{noformat}

But it failed with the following message:

{noformat}
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 0.579 s
[INFO] Finished at: 2016-11-19T19:55:06+13:00
[INFO] Final Memory: 10M/238M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.apache.commons:commons-weaver-maven-plugin:1.4-SNAPSHOT:help
(default-cli) on project weaver-example: Execution default-cli of goal org.apache.commons:commons-weaver-maven-plugin:1.4-SNAPSHOT:help
failed: Unable to load the mojo 'help' in the plugin 'org.apache.commons:commons-weaver-maven-plugin:1.4-SNAPSHOT'.
A required class is missing: HelpMojo
[ERROR] -----------------------------------------------------
[ERROR] realm =    plugin>org.apache.commons:commons-weaver-maven-plugin:1.4-SNAPSHOT
[ERROR] strategy = org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy
[ERROR] urls[0] = file:/home/kinow/.m2/repository/org/apache/commons/commons-weaver-maven-plugin/1.4-SNAPSHOT/commons-weaver-maven-plugin-1.4-SNAPSHOT.jar
[ERROR] urls[1] = file:/home/kinow/.m2/repository/org/apache/commons/commons-weaver-privilizer-api/1.4-SNAPSHOT/commons-weaver-privilizer-api-1.4-SNAPSHOT.jar
[ERROR] urls[2] = file:/home/kinow/.m2/repository/org/apache/commons/commons-weaver-privilizer/1.4-SNAPSHOT/commons-weaver-privilizer-1.4-SNAPSHOT.jar
[ERROR] urls[3] = file:/home/kinow/.m2/repository/org/apache/commons/commons-weaver-processor/1.4-SNAPSHOT/commons-weaver-processor-1.4-SNAPSHOT.jar
[ERROR] urls[4] = file:/home/kinow/.m2/repository/org/apache/xbean/xbean-finder-shaded/4.5/xbean-finder-shaded-4.5.jar
[ERROR] urls[5] = file:/home/kinow/.m2/repository/org/apache/xbean/xbean-asm5-shaded/4.5/xbean-asm5-shaded-4.5.jar
[ERROR] urls[6] = file:/home/kinow/.m2/repository/org/apache/commons/commons-lang3/3.4/commons-lang3-3.4.jar
[ERROR] urls[7] = file:/home/kinow/.m2/repository/org/apache/commons/commons-collections4/4.1/commons-collections4-4.1.jar
[ERROR] urls[8] = file:/home/kinow/.m2/repository/commons-io/commons-io/2.5/commons-io-2.5.jar
[ERROR] urls[9] = file:/home/kinow/.m2/repository/org/codehaus/plexus/plexus-utils/2.0.6/plexus-utils-2.0.6.jar
[ERROR] urls[10] = file:/home/kinow/.m2/repository/org/eclipse/aether/aether-util/1.1.0/aether-util-1.1.0.jar
[ERROR] Number of foreign imports: 1
[ERROR] import: Entry[import  from realm ClassRealm[maven.api, parent: null]]
[ERROR] 
[ERROR] -----------------------------------------------------
[ERROR] -> [Help 1]
[ERROR] 
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] 
[ERROR] For more information about the errors and possible solutions, please read the following
articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/PluginContainerException
{noformat}

If I try to run prepare with

{noformat}
mvn clean org.apache.commons:commons-weaver-maven-plugin:prepare
{noformat}

it works fine.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message