commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lukasz Lenart (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (OGNL-256) OGNL 3.0.19 (and many previous) do not work with SecurityManager Enabled
Date Tue, 11 Oct 2016 06:04:21 GMT

    [ https://issues.apache.org/jira/browse/OGNL-256?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15564596#comment-15564596
] 

Lukasz Lenart commented on OGNL-256:
------------------------------------

Also reported [here|https://github.com/jkuhnert/ognl/issues/31]

> OGNL 3.0.19 (and many previous) do not work with SecurityManager Enabled
> ------------------------------------------------------------------------
>
>                 Key: OGNL-256
>                 URL: https://issues.apache.org/jira/browse/OGNL-256
>             Project: Commons OGNL
>          Issue Type: Bug
>          Components: Core Runtime
>    Affects Versions: 3.0.13
>            Reporter: Michael Smith
>
> When using SecurityManager, we get the following error.
> java.lang.IllegalAccessException: Method [public java.lang.String com.opensymphony.xwork2.ActionSupport.execute()
throws java.lang.Exception] cannot be accessed.
> We used profilingSecurityManager to generate our policy file.. (but there could be issues)..
> Do you have a suitable example policy file for ognl that could be used.. we dont want
to have to set the OgnlRunTime.securityManger(null) hack.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message