commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <>
Subject [jira] [Commented] (LANG-1269) Wrong name or result of StringUtils::getJaroWinklerDistance
Date Sat, 22 Oct 2016 10:02:59 GMT


ASF GitHub Bot commented on LANG-1269:

Github user coveralls commented on the issue:
    [![Coverage Status](](
    Coverage increased (+0.004%) to 93.545% when pulling **d2e6338a8ec46ebc80156ef9dcdd83dfe63ee8b5
on PascalSchumacher:jarowinklerdistance_name** into **91d6bd74fa358fdc8d7cb7681c76c509fd9a8e7d
on apache:master**.

> Wrong name or result of StringUtils::getJaroWinklerDistance
> -----------------------------------------------------------
>                 Key: LANG-1269
>                 URL:
>             Project: Commons Lang
>          Issue Type: Bug
>    Affects Versions: 3.3, 3.4
>            Reporter: Jan Martin Keil
>            Assignee: Bruno P. Kinoshita
>            Priority: Minor
> The name of the method StringUtils::getJaroWinklerDistance is misleading.
> Currently for equal strings {{1}} is returned, for completely different strings {{0}}
is returned. That is a measure of similarity, not of a distance. A distance must be {{0}}
for equal strings. I read on the issues LANG-591 and LANG-944, that it was decided to have
a similar name to StringUtils::getLevenshteinDistance, but that requires also the change of
the methods result.
> Could you please (1) rename the method to StringUtils::getJaroWinklerSimilarity or (2)
change the method to return {{1 - currentResult}}?
> First option has the disadvantage to lose the similar naming of the similar methods,
second option implies the risk to unnoticed introduce bugs in depending code. So I think it
is preferable to use the first option.

This message was sent by Atlassian JIRA

View raw message