commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dapeng Sun (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CRYPTO-103) NativeCodeLoader.getVersion() is not needed
Date Mon, 11 Jul 2016 08:20:11 GMT

     [ https://issues.apache.org/jira/browse/CRYPTO-103?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Dapeng Sun updated CRYPTO-103:
------------------------------
    Assignee: Dapeng Sun

> NativeCodeLoader.getVersion() is not needed
> -------------------------------------------
>
>                 Key: CRYPTO-103
>                 URL: https://issues.apache.org/jira/browse/CRYPTO-103
>             Project: Commons Crypto
>          Issue Type: Bug
>            Reporter: Sebb
>            Assignee: Dapeng Sun
>             Fix For: 1.0.0
>
>
> The NativeCodeLoader.getVersion() method seems badly named, as it has nothing to do with
the native code that has been loaded.
> It only relates to the version of the Java code in the jar.
> I would expect the method to return the version details from the library itself.
> If there is a need to return the Java code version, it should be done from a method in
another class, e.g. Utils or Crypto. Note: also the extraction should be done once, e.g. using
IODH or using a synchronised/volatile lock.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message