commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dapeng Sun (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CRYPTO-103) NativeCodeLoader.getVersion() seems badly named
Date Thu, 07 Jul 2016 09:29:10 GMT

    [ https://issues.apache.org/jira/browse/CRYPTO-103?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15365869#comment-15365869
] 

Dapeng Sun commented on CRYPTO-103:
-----------------------------------

Thank Sebb, since the version is only used at loading native. I prefer to change method name
to getCryptoVersion and remove the Crypto#getVersion(). 

{quote} also the extraction should be done once, e.g. using IODH or using a synchronised/volatile
lock.{quote}
In fact, the method is called at static block and is limit usage from outside, I think we
don't need to add a lock.

Do you have any comment?

> NativeCodeLoader.getVersion() seems badly named
> -----------------------------------------------
>
>                 Key: CRYPTO-103
>                 URL: https://issues.apache.org/jira/browse/CRYPTO-103
>             Project: Commons Crypto
>          Issue Type: Bug
>            Reporter: Sebb
>
> The NativeCodeLoader.getVersion() method seems badly named, as it has nothing to do with
the native code that has been loaded.
> It only relates to the version of the Java code in the jar.
> I would expect the method to return the version details from the library itself.
> If there is a need to return the Java code version, it should be done from a method in
another class, e.g. Utils or Crypto. Note: also the extraction should be done once, e.g. using
IODH or using a synchronised/volatile lock.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message