commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joerg Schaible (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (COLLECTIONS-590) MapUtils.EMPTY_SORTED_MAP should be renamed - UnmodifiableSortedMap
Date Wed, 08 Jun 2016 14:52:21 GMT

     [ https://issues.apache.org/jira/browse/COLLECTIONS-590?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Joerg Schaible resolved COLLECTIONS-590.
----------------------------------------
    Resolution: Won't Fix

The names follow the same logic as their counter parts in the JDK. An empty sorted map is
always empty and therefore implicitly unmodifiable.

> MapUtils.EMPTY_SORTED_MAP should be renamed - UnmodifiableSortedMap
> -------------------------------------------------------------------
>
>                 Key: COLLECTIONS-590
>                 URL: https://issues.apache.org/jira/browse/COLLECTIONS-590
>             Project: Commons Collections
>          Issue Type: Improvement
>            Reporter: Philipp Schneider
>            Priority: Minor
>
> When using the constant MapUtils.EMPTY_SORTED_MAP I assume from the name, that it will
return an empty sorted map.
> But the map is an UnmodifiableSortedMap.
> The Javadoc says this, but still the naming is not really good.
> I suggest the following new name: EMPTY_UNMODIFIABLE_SORTED_MAP



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message