commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Artem Barger (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MATH-1372) Add argmin/argmax static functions to MathArrays utility class
Date Wed, 01 Jun 2016 14:27:59 GMT

    [ https://issues.apache.org/jira/browse/MATH-1372?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15310384#comment-15310384
] 

Artem Barger commented on MATH-1372:
------------------------------------

Would you like me to update my PR with my version of: 

{code}
    private static int argMinOrMax(final double[] data,
                                   boolean isMin) {
        if (data == null ||
                data.length == 0) {
            return -1;
        }

        int index = 0;
        int direction = (isMin) ? 1 : -1;
        double selected = direction * data[0];

        for (int i = 1; i < data.length; i++) {
            final double current = direction * data[i];
            if (current < selected) {
                index = i;
                selected = current;
            }
        }
        return index;
    }
{code}

?

> Add argmin/argmax static functions to MathArrays utility class
> --------------------------------------------------------------
>
>                 Key: MATH-1372
>                 URL: https://issues.apache.org/jira/browse/MATH-1372
>             Project: Commons Math
>          Issue Type: Wish
>            Reporter: Artem Barger
>            Assignee: Artem Barger
>            Priority: Trivial
>         Attachments: MATH-1372.patch
>
>
> Following conversation in the ML thread.
> Working lately w/ CM, I've found myself using a lot functions which helps to identify
the index of the min/max elements in given array of doubles. 
> In ML it was pointed out that similar functionality already exists in RealVector, however
due to MATH-765 it's planned to be removed (deprecated), moreover to use it one has to create
an instance of RealVector, where for simple cases it might be redundant.
> Hence I'd like to propose to add these static methods to the MathArrays utility class.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message