commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jerry Chen (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CRYPTO-33) SecureRandom shadows JVM class
Date Fri, 29 Apr 2016 02:36:12 GMT

    [ https://issues.apache.org/jira/browse/CRYPTO-33?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15263434#comment-15263434
] 

Jerry Chen commented on CRYPTO-33:
----------------------------------

When deciding the same name, we original has the same thoughts with Emmanuel Bourg. 
Unless, they use both Ciphers (Java Cipher and this Cipher) otherwise, developers will not
has the same clashes. The both Cipher has similar functionality, the developers usually has
no reason to use both Ciphers at same Java class. They will choose one or another.

If we finally to rename, I think we should name all classes consistent instead change only
those that conflicts. I consider the consistent names are very important for API usage. People
will have no idea why the CryptoInputStream is named in this way while CTRCipherInputStream
is named in another manner.

> SecureRandom shadows JVM class
> ------------------------------
>
>                 Key: CRYPTO-33
>                 URL: https://issues.apache.org/jira/browse/CRYPTO-33
>             Project: Commons Crypto
>          Issue Type: Bug
>            Reporter: Sebb
>            Assignee: Xianda Ke
>
> The SecureRandom interface also exists  as a class in java.security.
> This makes it awkward to use, for example in JavaSecureRandom the fully qualified name
has to be used for the java class.
> Ideally it should be renamed.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message