commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jerry Chen (JIRA)" <>
Subject [jira] [Commented] (CRYPTO-33) SecureRandom shadows JVM class
Date Wed, 27 Apr 2016 02:00:18 GMT


Jerry Chen commented on CRYPTO-33:

Thanks [] for pointing out this.

Thinking about this problem, we also has Cipher, CipherInputStream case with the same situation.
They are the best names in concept. 

Although there are possibilities that users may use both Java Cipher and our Cipher in the
same java file, yet can we consider this as an uncommon case so that we don't have to use
a "bad" name to address it.

Otherwise, we will have to use names like: CryptoCipher, CryptoSecureRandom, .. which are
very redundant and uncomfortable.

Any thoughts?

> SecureRandom shadows JVM class
> ------------------------------
>                 Key: CRYPTO-33
>                 URL:
>             Project: Commons Crypto
>          Issue Type: Bug
>            Reporter: Sebb
> The SecureRandom interface also exists  as a class in
> This makes it awkward to use, for example in JavaSecureRandom the fully qualified name
has to be used for the java class.
> Ideally it should be renamed.

This message was sent by Atlassian JIRA

View raw message