commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Xianda Ke (JIRA)" <>
Subject [jira] [Created] (CRYPTO-12) Names of CryptoInputStream & CryptoOutputStream
Date Fri, 22 Apr 2016 07:55:12 GMT
Xianda Ke created CRYPTO-12:

             Summary: Names of CryptoInputStream & CryptoOutputStream
                 Key: CRYPTO-12
             Project: Apache Commons Crypto
          Issue Type: Bug
            Reporter: Xianda Ke

It seems that "{color:red}Cipher{color}InputStream" and ''{color:red}Cipher{color}OutputStream'
are more friendly to the users who are familar with Java Cryptography Extension(JCE).

Java(JCE) use the name 'CipherInputStream'  and 'CipherOutputStream'
(see javax.crypto.CipherInputStream &  javax.crypto.CipherOutputStream).

btw, Bouncy Castle Crypto library also use the name '[CipherInputStream|]'
 and '[CipherOutputStream|]'.

This message was sent by Atlassian JIRA

View raw message