commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dian Fu (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CRYPTO-12) Rename CryptoInputStream to CipherInputStream and CryptoOutputStream to CipherOutputStream
Date Tue, 26 Apr 2016 03:42:13 GMT

    [ https://issues.apache.org/jira/browse/CRYPTO-12?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15257506#comment-15257506
] 

Dian Fu commented on CRYPTO-12:
-------------------------------

+1. Committed. Thanks [~kexianda] for your contribution.

> Rename CryptoInputStream to CipherInputStream and CryptoOutputStream to CipherOutputStream
> ------------------------------------------------------------------------------------------
>
>                 Key: CRYPTO-12
>                 URL: https://issues.apache.org/jira/browse/CRYPTO-12
>             Project: Commons Crypto
>          Issue Type: Improvement
>            Reporter: Xianda Ke
>            Assignee: Xianda Ke
>
> It seems that "{color:red}Cipher{color}InputStream" and ''{color:red}Cipher{color}OutputStream'
are more friendly to the users who are familar with Java Cryptography Extension(JCE).
> Java(JCE) use the name 'CipherInputStream'  and 'CipherOutputStream'
> (see javax.crypto.CipherInputStream &  javax.crypto.CipherOutputStream).
> btw, Bouncy Castle Crypto library also use the name '[CipherInputStream|https://github.com/bcgit/bc-java/blob/master/core/src/main/java/org/bouncycastle/crypto/io/CipherInputStream.java]'
 and '[CipherOutputStream|https://github.com/bcgit/bc-java/blob/master/core/src/main/java/org/bouncycastle/crypto/io/CipherOutputStream.java]'.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message