commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "neal zhang11 (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (COLLECTIONS-585) When use commons collection 3.2.2, show "JavaSE not found"
Date Fri, 29 Jan 2016 02:57:39 GMT

     [ https://issues.apache.org/jira/browse/COLLECTIONS-585?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

neal zhang11 updated COLLECTIONS-585:
-------------------------------------
    Description: 
Hi all, when i use commons-collections 3.2.2, and build my rcp application. it always show
this error:
  [java] [eclipse.generateFeature] Some inter-plug-in dependencies have not been satisfied.
     [java] [eclipse.generateFeature] Bundle org.apache.commons.collections:
     [java] [eclipse.generateFeature] 	Host plug-in JavaSE_0.0.0 has not been found.

but for commons-collections 3.2.1.every thing is fine. 
and compared the 3.2.2 and 3.2.1 
Mainfest.mf file add this:
Require-Capability: osgi.ee;filter:="(&(osgi.ee=JavaSE)(version=1.3))"
if remove it, i can build my application. 
i use jdk1.7 in my local(i also tested jdk1.8, same problem)
so i don't understand why show this problem.



  was:
Hi all, when i use commons-collections 3.2.2, and build my rcp application. it always show
this error:
  [java] [eclipse.generateFeature] Some inter-plug-in dependencies have not been satisfied.
     [java] [eclipse.generateFeature] Bundle org.apache.commons.collections:
     [java] [eclipse.generateFeature] 	Host plug-in JavaSE_0.0.0 has not been found.

but for commons-collections 3.2.1.every thing is fine. 
and compared the 3.2.2 and 3.2.1 
Mainfest.mf file add this:
Require-Capability: osgi.ee;filter:="(&(osgi.ee=JavaSE)(version=1.3))"
if remove it, i can build my application. 
i use jdk1.7 in my local(i also tested jdk1.8, same problem)
so i don't understand why show this problem.



> When use commons collection 3.2.2, show "JavaSE not found"
> ----------------------------------------------------------
>
>                 Key: COLLECTIONS-585
>                 URL: https://issues.apache.org/jira/browse/COLLECTIONS-585
>             Project: Commons Collections
>          Issue Type: Bug
>          Components: Collection
>    Affects Versions: 3.2.2
>         Environment: jdk1.7 commons-collections 3.2.2
>            Reporter: neal zhang11
>            Priority: Minor
>
> Hi all, when i use commons-collections 3.2.2, and build my rcp application. it always
show this error:
>   [java] [eclipse.generateFeature] Some inter-plug-in dependencies have not been satisfied.
>      [java] [eclipse.generateFeature] Bundle org.apache.commons.collections:
>      [java] [eclipse.generateFeature] 	Host plug-in JavaSE_0.0.0 has not been found.
> but for commons-collections 3.2.1.every thing is fine. 
> and compared the 3.2.2 and 3.2.1 
> Mainfest.mf file add this:
> Require-Capability: osgi.ee;filter:="(&(osgi.ee=JavaSE)(version=1.3))"
> if remove it, i can build my application. 
> i use jdk1.7 in my local(i also tested jdk1.8, same problem)
> so i don't understand why show this problem.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message