commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Martin (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (DBUTILS-125) Using Oracle OJDBC7 gives ORA-00933
Date Wed, 27 Jan 2016 19:08:39 GMT

    [ https://issues.apache.org/jira/browse/DBUTILS-125?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15119981#comment-15119981
] 

David Martin edited comment on DBUTILS-125 at 1/27/16 7:08 PM:
---------------------------------------------------------------

It is not a DBUtils bug, definitely. It is a bug in the ojdbc7.jar Oracle JDBC Driver in the
PreparedStatement.getParameterMetaData method.

Please see http://stackoverflow.com/a/35033943/3371541

In my case, it was failing when doing an UPDATE on any column which name starts with F, H
or O .... and I am not kidding, after trying several queries those column names are misspelled
or simply disappear from the query.


was (Author: peter gibbons):

It is not a DBUtils bug, definitely. It is a bug in the ojdbc7.jar Oracle JDBC Driver in the
PreparedStatement.getParameterMetaData method.

Please see http://stackoverflow.com/a/35033943/3371541

In my case, it was failing when doing an UPDATE on any column which name starts with F, H
or O .... and I am not kidding, after trying several queries those column names are misspelled
or simply disappears from the query.

> Using Oracle OJDBC7 gives ORA-00933
> -----------------------------------
>
>                 Key: DBUTILS-125
>                 URL: https://issues.apache.org/jira/browse/DBUTILS-125
>             Project: Commons DbUtils
>          Issue Type: Bug
>    Affects Versions: 1.6
>         Environment: JDBC driver version is 12.1.0.1.0
>            Reporter: EMR
>            Priority: Minor
>         Attachments: JavaApplication35NoDbUtils.tar.bz2, JavaApplication35WithDbUtils.tar.bz2
>
>
> Attempting to run an sql query with the latest version of the drivers, it fails with
ERROR (JavaApplication33.java:107) - ORA-00933: SQL command not properly ended.
> However, if I revert to the 11 version of the driver, the query works fine. Is there
a setting that I am missing between the two versions?



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message