commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michele Vivoda (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (JXPATH-184) Update to Java 7
Date Wed, 25 Nov 2015 02:55:11 GMT

    [ https://issues.apache.org/jira/browse/JXPATH-184?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15026067#comment-15026067
] 

Michele Vivoda commented on JXPATH-184:
---------------------------------------

Hi,
thanks for the work done in the last times, fantastic to see some action.

About this issue: just for reference, up to now jxpath 1.4-SNAPSHOT was java 4 (and junit
3.8.1). I agree at some point it could upgrade, I am not sure about doing it in jxpath 1.4
that has many bug fixes and up to now is compatible with 1.3, that is the latest binary/Maven
release. 

I would suggest to fix JXPATH-173  keeping JXPATH 1.4 as the last compatible with JDK1.4 and
the previous versions of JXPath. Then start a JXPATH 1.5 with a newer JDK.  To me 1.7 seems
"too much", I checked for example Commons IO and is JDK1.6/5, not 7. Not sure about what would
be actually needed from 1.7

> Update to Java 7
> ----------------
>
>                 Key: JXPATH-184
>                 URL: https://issues.apache.org/jira/browse/JXPATH-184
>             Project: Commons JXPath
>          Issue Type: Task
>            Reporter: Benedikt Ritter
>            Assignee: Benedikt Ritter
>             Fix For: 1.4
>
>




--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message