commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Santhosh Anand Ramia (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (JCS-100) JCS never going out of the dispose methode
Date Fri, 02 Oct 2015 19:40:26 GMT

    [ https://issues.apache.org/jira/browse/JCS-100?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14941628#comment-14941628
] 

Santhosh Anand Ramia commented on JCS-100:
------------------------------------------

Hi Jean-Marc Spaggiari,

Did you latest build fix the problem. I am having the same problem now. 

> JCS never going out of the dispose methode
> ------------------------------------------
>
>                 Key: JCS-100
>                 URL: https://issues.apache.org/jira/browse/JCS-100
>             Project: Commons JCS
>          Issue Type: Bug
>          Components: Composite Cache
>    Affects Versions: jcs-1.3
>         Environment: Windows
>            Reporter: Jean-Marc Spaggiari
>
> I have an application using many threads all calling JCS. When I close the application,
the cache is usually working fine, but sometime, it stays stucked on the dispose methode.
> The cacheEventQueue never going empty. Then it's looping on while ( keepGoing ) and never
ending. I have to kill the application to exit.
> It's difficult to reproduce. There is no fixed pattern so far.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message