commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sebb (JIRA)" <j...@apache.org>
Subject [jira] [Created] (BCEL-240) Should UnsupportedClassVersionError be defined in ExceptionConstants?
Date Wed, 12 Aug 2015 16:41:46 GMT
Sebb created BCEL-240:
-------------------------

             Summary: Should UnsupportedClassVersionError be defined in ExceptionConstants?
                 Key: BCEL-240
                 URL: https://issues.apache.org/jira/browse/BCEL-240
             Project: Commons BCEL
          Issue Type: Improvement
            Reporter: Sebb


The ExceptionConstants class has a comment:

{quote}
    /* UnsupportedClassVersionError is new in JDK 1.2 */
//    public static final Class UnsupportedClassVersionError = UnsupportedClassVersionError.class;
{quote}

Given that JDK 1.1 is now pre-historic, would it make sense to enable the constant (upcasing
the name)? Is there any reason why the constant should not be defined?




--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message