commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Volker Berlin (JIRA)" <j...@apache.org>
Subject [jira] [Created] (DAEMON-335) prunsrv does not start with jvm mode
Date Fri, 10 Jul 2015 12:04:05 GMT
Volker Berlin created DAEMON-335:
------------------------------------

             Summary: prunsrv does not start with jvm mode
                 Key: DAEMON-335
                 URL: https://issues.apache.org/jira/browse/DAEMON-335
             Project: Commons Daemon
          Issue Type: Bug
          Components: Procrun
    Affects Versions: 1.0.15, 1.0.14, 1.0.13, 1.0.12, 1.0.11
         Environment: Windows 8.1 with Java 8 64bit
            Reporter: Volker Berlin
            Priority: Critical


If I start my service in the jvm mode then it terminate immediate. in the log I see:

[info]  ( prunsrv.c:1127) [ 4060] Starting service...
[debug] ( javajni.c:233 ) [ 4060] loading jvm 'C:\jre\bin\server\jvm.dll'
[debug] ( javajni.c:704 ) [ 5972] Jvm Option[0] -Djava.class.path=foo.jar
[debug] ( javajni.c:704 ) [ 5972] Jvm Option[1] exit
[debug] ( javajni.c:941 ) [ 5972] Java Worker thread started com/foo/Foo:main
[debug] ( javajni.c:471 ) [ 5404] Exit hook with exit code 1

---------------------
If I start it from the console then I see then I see:

Could not find or load main class exit

--------------------
The problem occur since version 1.11. With version 1.10 all is working. It is related to DAEMON-244.


A workaround is to use the Java mode instead of the jvm mode.




--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message