commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Benedikt Ritter (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (IO-478) Rename org.apache.commons.io.output.ByteArrayOutputStream
Date Tue, 26 May 2015 08:21:17 GMT

    [ https://issues.apache.org/jira/browse/IO-478?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14558845#comment-14558845
] 

Benedikt Ritter commented on IO-478:
------------------------------------

Okay, looks like I'm the only one who had a problem with the name collision. I'm fine with
closing as won't fix if nobody else sees a problem here.

> Rename org.apache.commons.io.output.ByteArrayOutputStream
> ---------------------------------------------------------
>
>                 Key: IO-478
>                 URL: https://issues.apache.org/jira/browse/IO-478
>             Project: Commons IO
>          Issue Type: Task
>          Components: Streams/Writers
>            Reporter: Benedikt Ritter
>             Fix For: 3.x
>
>
> The name of org.apache.commons.io.output.ByteArrayOutputStream clashes with java.io.ByteArrayOutputStream
which can cause confusion. We should rename the class to something that better describes its
behavior and differences to java.io.ByteArrayOutputStream, for example GrowingByteArrayOutputStream.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message