commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thomas Neidhart (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MATH-643) Rename RealVector.map* to RealVector.ebe* (mapAdd(...) to ebeAdd(...) and mapAddToSelf(...) to ebeAddToSelf(...) for instance
Date Mon, 02 Mar 2015 21:07:04 GMT

    [ https://issues.apache.org/jira/browse/MATH-643?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14343760#comment-14343760
] 

Thomas Neidhart commented on MATH-643:
--------------------------------------

element-by-element is simply the wrong term for this kind of operation.

The referenced page of octave also makes the distinction between element-by-element operations
and overloaded operations with different operands.

The prefix map comes from the functional world and is well understood imho.

As we have not deprecated anything in 3.x and the proposal is not very convincing for me,
I propose to close it finally as won't fix.

> Rename RealVector.map* to RealVector.ebe* (mapAdd(...) to ebeAdd(...) and mapAddToSelf(...)
to ebeAddToSelf(...) for instance
> -----------------------------------------------------------------------------------------------------------------------------
>
>                 Key: MATH-643
>                 URL: https://issues.apache.org/jira/browse/MATH-643
>             Project: Commons Math
>          Issue Type: Improvement
>            Reporter: Arne Plöse
>            Priority: Minor
>             Fix For: 4.0
>
>
> I think the map* methods have historical names. Today I would prefer ebe as prefix like
ebeMultiply(...).
> This would describe the methods better from a users view.
> If this is a valid issue, I could provide a patch.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message