commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "vibin (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (DAEMON-330) Error when start the service.
Date Tue, 17 Feb 2015 15:41:13 GMT

     [ https://issues.apache.org/jira/browse/DAEMON-330?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

vibin updated DAEMON-330:
-------------------------

And here is the install script:
@echo off
set SERVICE_NAME=boptAgent

set PR_INSTALL=%BOPT_HOME%\bopt_pe_kit\boptAgent.exe
 
@REM Service Log Configuration
set PR_LOGPATH=%BOPT_HOME%\logs
set PR_STDOUTPUT=auto
set PR_STDERROR=auto
set PR_LOGLEVEL=Debug
 
@REM Path to Java Installation
set JAVA_HOME=C:\Program Files\Java\jdk1.7.0_75
set PR_JVM=%JAVA_HOME%\jre\bin\server\jvm.dll
set PR_CLASSPATH=%BOPT_HOME%\bopt_pe_kit\boptAgent.jar;%JAVA_HOME%\lib\tools.jar
 
@REM JVM Configuration
set PR_JVMMS=128
set PR_JVMMX=512
set PR_JVMSS=4000
@REM Startup Configuration
set START_CLASS=xxxx.xxxxx.backupOptimizer.agent.AgentService
set START_METHOD=start
set STOP_METHOD=stop
 
set PR_STARTUP=auto
set PR_STARTMODE=java
set PR_STARTCLASS=%START_CLASS%
 
@REM Shutdown Configuration
set PR_STOPMODE=java
set PR_STOPCLASS=%START_CLASS%

 
%PR_INSTALL% //IS/%SERVICE_NAME% ^
  --DisplayName="%SERVICE_NAME%" ^
  --Install="%PR_INSTALL%" ^
  --Startup="%PR_STARTUP%" ^
  --LogPath="%PR_LOGPATH%" ^
  --LogPrefix="%PR_LOGPREFIX%" ^
  --LogLevel="%PR_LOGLEVEL%" ^
  --StdOutput="%PR_STDOUTPUT%" ^
  --StdError="%PR_STDERROR%" ^
  --JavaHome="%JAVA_HOME%" ^
  --Jvm="%PR_JVM%" ^
  --JvmMs="%PR_JVMMS%" ^
  --JvmMx="%PR_JVMMX%" ^
  --JvmSs="%PR_JVMSS%" ^
  --Classpath="%PR_CLASSPATH%" ^
  --StartMode="%PR_STARTMODE%" ^
  --StartClass="%START_CLASS%" ^
  --StartMethod="%START_METHOD%" ^
  --StopMode="%PR_STOPMODE%" ^
  --StopClass="%STOP_CLASS%" ^
  --StopMethod="%STOP_METHOD%"
 
if not errorlevel 1 goto installed
echo Failed to install "%SERVICE_NAME%" service.  Refer to log in %PR_LOGPATH%
goto end
 
:installed
echo The Service "%SERVICE_NAME%" has been installed
 
:end

> Error when start the service.
> -----------------------------
>
>                 Key: DAEMON-330
>                 URL: https://issues.apache.org/jira/browse/DAEMON-330
>             Project: Commons Daemon
>          Issue Type: Bug
>          Components: Procrun
>    Affects Versions: 1.0.15
>         Environment: Windows 7, Java 7.
>            Reporter: vibin
>
> I am creating a Windows Service by wrapping a java Application built on java 7. I use
64 bit windows 7 to test the service.
> Service installed without an error, but when i try to start the service ( re-named_prunSrvc.exe
//TS) , it is terminating with a warring message. Screenshot attached.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message