commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joseph Fitzgerald (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (IMAGING-158) Color component names should follow naming conventions
Date Tue, 03 Feb 2015 14:57:35 GMT

    [ https://issues.apache.org/jira/browse/IMAGING-158?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14303372#comment-14303372
] 

Joseph Fitzgerald commented on IMAGING-158:
-------------------------------------------

I would think that you'd want to be consistent...

both short:
ColorCmy.c
or both long:
ColorCyanMagentaYellow.cyan

> Color component names should follow naming conventions
> ------------------------------------------------------
>
>                 Key: IMAGING-158
>                 URL: https://issues.apache.org/jira/browse/IMAGING-158
>             Project: Commons Imaging
>          Issue Type: Improvement
>          Components: imaging.color.*
>            Reporter: Benedikt Ritter
>
> Checkstyle reports a lot of errors because the fields of our color classes are just single
capital letters. I'm currently thinking about renaming them to their full names, so that {{ColorCmy.C}}
becomes {{ColorCmy.cyan}}. Don't know if that feels better from an API user's POV. It's longer
by it's more explicit.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message