commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thomas Neidhart (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MATH-839) In "RealDistribution" implementations, rename method "cumulativeProbability(double,double)" to "probability(double,double)"
Date Tue, 24 Feb 2015 22:14:04 GMT

    [ https://issues.apache.org/jira/browse/MATH-839?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14335556#comment-14335556
] 

Thomas Neidhart commented on MATH-839:
--------------------------------------

Is there a special reason why the cumulativeProbability method has only been deprecated for
RealDistribution but not for IntegerDistribution?

> In "RealDistribution" implementations, rename method "cumulativeProbability(double,double)"
to "probability(double,double)"
> ---------------------------------------------------------------------------------------------------------------------------
>
>                 Key: MATH-839
>                 URL: https://issues.apache.org/jira/browse/MATH-839
>             Project: Commons Math
>          Issue Type: Task
>    Affects Versions: 3.0
>            Reporter: Gilles
>            Assignee: Gilles
>            Priority: Trivial
>              Labels: api-change
>             Fix For: 4.0
>
>
> Cf. http://en.wikipedia.org/wiki/Cumulative_distribution_function
> Cf. http://en.wikipedia.org/wiki/Probability_density_function
> The method currently named "cumulativeProbability(double,double)" in fact provides the
_probability_ of the variable to be within the given interval. The name "probability" would
thus be more accurate (and shorter).



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message