commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thomas Neidhart (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (MATH-839) In "RealDistribution" implementations, rename method "cumulativeProbability(double,double)" to "probability(double,double)"
Date Wed, 25 Feb 2015 20:45:04 GMT

     [ https://issues.apache.org/jira/browse/MATH-839?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Thomas Neidhart resolved MATH-839.
----------------------------------
    Resolution: Fixed

Changed in commit 3fd9cf1753a24587ee9d64d2133784adaa099219.

> In "RealDistribution" implementations, rename method "cumulativeProbability(double,double)"
to "probability(double,double)"
> ---------------------------------------------------------------------------------------------------------------------------
>
>                 Key: MATH-839
>                 URL: https://issues.apache.org/jira/browse/MATH-839
>             Project: Commons Math
>          Issue Type: Task
>    Affects Versions: 3.0
>            Reporter: Gilles
>            Assignee: Gilles
>            Priority: Trivial
>              Labels: api-change
>             Fix For: 4.0
>
>
> Cf. http://en.wikipedia.org/wiki/Cumulative_distribution_function
> Cf. http://en.wikipedia.org/wiki/Probability_density_function
> The method currently named "cumulativeProbability(double,double)" in fact provides the
_probability_ of the variable to be within the given interval. The name "probability" would
thus be more accurate (and shorter).



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message