commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stefan Bodewig (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (COMPRESS-284) Multi Thread Uncompress TGZ - CRC32 ERROR
Date Sun, 31 Aug 2014 19:23:21 GMT

    [ https://issues.apache.org/jira/browse/COMPRESS-284?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14116860#comment-14116860
] 

Stefan Bodewig commented on COMPRESS-284:
-----------------------------------------

I have tried to come up with a test case that exhibits the same problem but don't seem to
be able to.  Unless we find a way to reproduce the issue at all I don't see how to move on.

> Multi Thread Uncompress TGZ - CRC32 ERROR
> -----------------------------------------
>
>                 Key: COMPRESS-284
>                 URL: https://issues.apache.org/jira/browse/COMPRESS-284
>             Project: Commons Compress
>          Issue Type: Bug
>    Affects Versions: 1.8.1
>         Environment: Linux
>            Reporter: Inspico
>
> We have to uncompress ".tar.gz".
> So we use an "TarArchiveInputStream(GzipCompressorInputStream)".
> An archive extracted alone works perfectly.
> But when we have to launch paralleles thread to extract many archives at the same time
we get the same error for each thread :
> java.lang.Exception: Error while extracting list of files from Archive : java.io.IOException:
Gzip-compressed data is corrupt (CRC32 error)
> Sometimes we may have a success for only one archive among all errors.
> Is there any problems on the use of TarInputStream or GZIPInputStream in multi-thread
?



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message