commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Romain Manni-Bucau (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LANG-1027) org.apache.commons.lang3.SystemUtils#isJavaVersionAtLeast should return true by default
Date Sun, 20 Jul 2014 11:32:38 GMT

    [ https://issues.apache.org/jira/browse/LANG-1027?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14067890#comment-14067890
] 

Romain Manni-Bucau commented on LANG-1027:
------------------------------------------

Hehe, true, not yet used to it. Added JAVA_RECENT as version to solve it. Actually current
model could be reworked since java 1.10 will more or less break it as far as I saw and java
2.x will not be supported. JAVA_RECENT should tolerate it (goal of this task) but this is
not the nominal case.

Pushed a fix. Will surely need some cycles to get it right since it poped up previous issues.

> org.apache.commons.lang3.SystemUtils#isJavaVersionAtLeast should return true by default
> ---------------------------------------------------------------------------------------
>
>                 Key: LANG-1027
>                 URL: https://issues.apache.org/jira/browse/LANG-1027
>             Project: Commons Lang
>          Issue Type: Improvement
>            Reporter: Romain Manni-Bucau
>             Fix For: 3.4
>
>
> Hi
> last [lang] release doesn't support java 9 (not in JavaVersion enum). However it shouldn't
break the org.apache.commons.lang3.SystemUtils#isJavaVersionAtLeast method which should return
true when java version is not known (not known = older)
> My proposal is to add UNKNOWN to the enum and override atLeast for this particular value
to return true.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message