commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Benedikt Ritter (JIRA)" <>
Subject [jira] [Commented] (SANDBOX-462) Refactoring of AccessibleObjectsRegistry
Date Sat, 08 Mar 2014 12:38:43 GMT


Benedikt Ritter commented on SANDBOX-462:

Hi André,

any hints how to check the rules and format the code already on my site? Do you have a code
style config for your IDE? Do you run checkstyle locally? Currently I don't even know what
I messed up exactly :-/

I've changed the site build of BeanUtils2 to use commons parent pom.xml. You can now call
mvn site again. It will generate the component website into the target directory. Just open
index.html and have a look at the check style report. There a currently a lot of violations
already that we will need to fix and contributions should at best not introduce any new violations


> Refactoring of AccessibleObjectsRegistry
> ----------------------------------------
>                 Key: SANDBOX-462
>                 URL:
>             Project: Commons Sandbox
>          Issue Type: Improvement
>          Components: BeanUtils2
>            Reporter: Andre Diermann
>            Priority: Minor
>         Attachments: Commons-BeanUtils2-462#1.patch
> Summary:
> The AccessibleObjectsRegistry class provides two get methods, while one is a convenient
method for the other.
> Both methods take one conditional parameter, boolean exact, and the actual get method
is very long, which makes it somehow complex to understand.
> Suggestion:
> What could be improved IMHO:
> - Instead of using conditional methods, like get(boolean doSomethingSpecialIfTrue, ...),
it is more convenient to provide dedicated methods like getSomething() and getAnotherThing().
> - In this regard the difference between an exact or, let's call it, matching descriptor
should be expressed through inheritance rather than object allocation (= expressing it by
a field boolean exact).
> - The very long get method should be refined
> - Another very minor issue is the naming of the paramTypes field within the inner AccessibleObjectDescriptor
class, which I would suggest to rename to parameterTypes to fit the naming of the other occurrences.

This message was sent by Atlassian JIRA

View raw message