commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andre Diermann (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (SANDBOX-462) Refactoring of AccessibleObjectsRegistry
Date Sun, 16 Feb 2014 11:36:19 GMT

     [ https://issues.apache.org/jira/browse/SANDBOX-462?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Andre Diermann updated SANDBOX-462:
-----------------------------------

    Description: 
Summary:
The AccessibleObjectsRegistry class provides two get methods, while one is a convenient method
for the other.

Both methods take one conditional parameter, boolean exact, and the actual get method is very
long, which makes it somehow complex to understand.

Suggestion:
What could be improved IMHO:
- Instead of using conditional methods, like get(boolean doSomethingSpecialIfTrue, ...), it
is more convenient to provide dedicated methods like getSomething() and getAnotherThing().
- In this regard the difference between an exact or, let's call it, matching descriptor should
be expressed through inheritance rather than object allocation (= expressing it by a field
boolean exact).
- Another very minor issue is the naming of the paramTypes field within the inner AccessibleObjectDescriptor
class, which I would suggest to rename to parameterTypes to fit the naming of the other occurrences.


  was:
The AccessibleObjectsRegistry class provides two get methods, while one is a convenient method
for the other.

Both methods take one conditional parameter, boolean exact, and the actual get method is very
long, which makes it somehow complex to understand.

What could be improved IMHO:
- Instead of using conditional methods, like get(boolean doSomethingSpecialIfTrue, ...), it
is more convenient to provide dedicated methods like getSomething() and getAnotherThing().
- In this regard the difference between an exact or, let's call it, matching descriptor should
be expressed through inheritance rather than object allocation (= expressing it by a field
boolean exact).
- Another very minor issue is the naming of the paramTypes field within the inner AccessibleObjectDescriptor
class, which I would suggest to rename to parameterTypes to fit the naming of the other occurrences.



> Refactoring of AccessibleObjectsRegistry
> ----------------------------------------
>
>                 Key: SANDBOX-462
>                 URL: https://issues.apache.org/jira/browse/SANDBOX-462
>             Project: Commons Sandbox
>          Issue Type: Improvement
>          Components: BeanUtils2
>            Reporter: Andre Diermann
>            Priority: Minor
>         Attachments: Commons-BeanUtils2-462.patch
>
>
> Summary:
> The AccessibleObjectsRegistry class provides two get methods, while one is a convenient
method for the other.
> Both methods take one conditional parameter, boolean exact, and the actual get method
is very long, which makes it somehow complex to understand.
> Suggestion:
> What could be improved IMHO:
> - Instead of using conditional methods, like get(boolean doSomethingSpecialIfTrue, ...),
it is more convenient to provide dedicated methods like getSomething() and getAnotherThing().
> - In this regard the difference between an exact or, let's call it, matching descriptor
should be expressed through inheritance rather than object allocation (= expressing it by
a field boolean exact).
> - Another very minor issue is the naming of the paramTypes field within the inner AccessibleObjectDescriptor
class, which I would suggest to rename to parameterTypes to fit the naming of the other occurrences.




--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message