commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Benedikt Ritter (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SANDBOX-462) Refactoring of AccessibleObjectsRegistry
Date Thu, 27 Feb 2014 15:43:25 GMT

    [ https://issues.apache.org/jira/browse/SANDBOX-462?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13914666#comment-13914666
] 

Benedikt Ritter commented on SANDBOX-462:
-----------------------------------------

Hello André

usually I've used mvn site and then looked at the check style report on the generated site.
Unfortunately the site build is currently broken. I have to either release a new version of
the sandbox parent pom find a different solution for this problem.

To see what I've changed you can call

{code}
svn diff -r 1570311:1570312 src/main/java/org/apache/commons/beanutils2/AccessibleObjectsRegistry.java
{code}

Was just about whitespaces, as you can see.

Regards,
Benedikt

> Refactoring of AccessibleObjectsRegistry
> ----------------------------------------
>
>                 Key: SANDBOX-462
>                 URL: https://issues.apache.org/jira/browse/SANDBOX-462
>             Project: Commons Sandbox
>          Issue Type: Improvement
>          Components: BeanUtils2
>            Reporter: Andre Diermann
>            Priority: Minor
>         Attachments: Commons-BeanUtils2-462#1.patch
>
>
> Summary:
> The AccessibleObjectsRegistry class provides two get methods, while one is a convenient
method for the other.
> Both methods take one conditional parameter, boolean exact, and the actual get method
is very long, which makes it somehow complex to understand.
> Suggestion:
> What could be improved IMHO:
> - Instead of using conditional methods, like get(boolean doSomethingSpecialIfTrue, ...),
it is more convenient to provide dedicated methods like getSomething() and getAnotherThing().
> - In this regard the difference between an exact or, let's call it, matching descriptor
should be expressed through inheritance rather than object allocation (= expressing it by
a field boolean exact).
> - The very long get method should be refined
> - Another very minor issue is the naming of the paramTypes field within the inner AccessibleObjectDescriptor
class, which I would suggest to rename to parameterTypes to fit the naming of the other occurrences.




--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message