commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Benedikt Ritter (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (LANG-963) Clarify behavior of StringEscapeUtils.escapeXml by renaming it to StringEscapeUtils.escapeXmlEntities
Date Sat, 15 Feb 2014 15:51:19 GMT

     [ https://issues.apache.org/jira/browse/LANG-963?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Benedikt Ritter resolved LANG-963.
----------------------------------

       Resolution: Won't Fix
    Fix Version/s:     (was: 3.3)

As discussed on the ML, we won't rename this method (see http://markmail.org/message/5jasck2gvvr4qp2l)

> Clarify behavior of StringEscapeUtils.escapeXml by renaming it to StringEscapeUtils.escapeXmlEntities
> -----------------------------------------------------------------------------------------------------
>
>                 Key: LANG-963
>                 URL: https://issues.apache.org/jira/browse/LANG-963
>             Project: Commons Lang
>          Issue Type: Improvement
>          Components: lang.*
>            Reporter: Benedikt Ritter
>            Assignee: Benedikt Ritter
>
> Although the documentation of {{StringEscaspeUtils.escapeXml(String)}} makes explicit
that the method can only handle the basic XML entities, this should be clarified by renaming
the method. The old method has be be deprecated and forwarded to the new method.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message