commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sebb (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (LANG-963) Clarify behavior of StringEscapeUtils.escapeXml by renaming it to StringEscapeUtils.escapeXmlEntities
Date Mon, 03 Feb 2014 23:15:07 GMT

     [ https://issues.apache.org/jira/browse/LANG-963?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Sebb updated LANG-963:
----------------------

    Summary: Clarify behavior of StringEscapeUtils.escapeXml by renaming it to StringEscapeUtils.escapeXmlEntities
 (was: Clarify behavior of StringEscapeUtils.escapeXml be renaming it to StringEscapeUtils.escapeXmlEntities)

> Clarify behavior of StringEscapeUtils.escapeXml by renaming it to StringEscapeUtils.escapeXmlEntities
> -----------------------------------------------------------------------------------------------------
>
>                 Key: LANG-963
>                 URL: https://issues.apache.org/jira/browse/LANG-963
>             Project: Commons Lang
>          Issue Type: Improvement
>          Components: lang.*
>            Reporter: Benedikt Ritter
>            Assignee: Benedikt Ritter
>             Fix For: 3.3
>
>
> Although the documentation of {{StringEscaspeUtils.escapeXml(String)}} makes explicit
that the method can only handle the basic XML entities, this should be clarified by renaming
the method. The old method has be be deprecated and forwarded to the new method.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message