commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Benedikt Ritter (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LANG-963) Clarify behavior of StringEscapeUtils.escapeXml be renaming it to StringEscapeUtils.escapeXmlEntities
Date Sat, 01 Feb 2014 11:48:08 GMT

    [ https://issues.apache.org/jira/browse/LANG-963?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13888546#comment-13888546
] 

Benedikt Ritter commented on LANG-963:
--------------------------------------

{{escapeHtml3}} and {{escapeHtml4}} also only escape entities and should be renamed likewise


> Clarify behavior of StringEscapeUtils.escapeXml be renaming it to StringEscapeUtils.escapeXmlEntities
> -----------------------------------------------------------------------------------------------------
>
>                 Key: LANG-963
>                 URL: https://issues.apache.org/jira/browse/LANG-963
>             Project: Commons Lang
>          Issue Type: Improvement
>          Components: lang.*
>            Reporter: Benedikt Ritter
>            Assignee: Benedikt Ritter
>             Fix For: 3.3
>
>
> Although the documentation of {{StringEscaspeUtils.escapeXml(String)}} makes explicit
that the method can only handle the basic XML entities, this should be clarified by renaming
the method. The old method has be be deprecated and forwarded to the new method.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message