commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Feysal Rujbally (JIRA)" <j...@apache.org>
Subject [jira] [Created] (DBUTILS-118) BeanProcessor not returning nanoseconds
Date Mon, 30 Dec 2013 09:12:53 GMT
Feysal Rujbally created DBUTILS-118:
---------------------------------------

             Summary: BeanProcessor not returning nanoseconds
                 Key: DBUTILS-118
                 URL: https://issues.apache.org/jira/browse/DBUTILS-118
             Project: Commons DbUtils
          Issue Type: Bug
    Affects Versions: 1.5
            Reporter: Feysal Rujbally
            Priority: Blocker


We are calling an SP to retrieve a timestamp from the DB but the mapping of the nano seconds
is not being done correctly. Only milliseconds are being returned although the SP is returning
the nano seconds.
After debugging through the apache db utils, we found that in the class BeanProcessor (method
callSetter), the setting of timestamp is not being done properly:

if ("java.sql.Timestamp".equals(targetType)) {
     value = new java.sql.Timestamp(((java.util.Date) value).getTime());
 }

We have modified the codes as follows so as to get the nano seconds:

if ("java.sql.Timestamp".equals(targetType))
{
 int nanos = ((Timestamp) value).getNanos(); 
value = new java.sql.Timestamp(((Timestamp) value).getTime());
 ((Timestamp) value).setNanos(nanos); 
} 

Can you please provide a fix as soon as possible. (v1.6 would be great)




--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message