commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gilles (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MATH-1057) BOBYQAOptimizerTest has two failing tests
Date Sun, 03 Nov 2013 22:33:18 GMT

    [ https://issues.apache.org/jira/browse/MATH-1057?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13812507#comment-13812507
] 

Gilles commented on MATH-1057:
------------------------------

The extreme sensitivity of some tests was noticed quite some time ago. The main problem is
that we introduced this algorithm into CM although the code was nowhere near to something
a Java programmer can understand. And this was already after I performed extensive work to
modify the code that had been auto-generated from the original FORTRAN implementation.
Further code readability improvements were stalled due to 
tests failing after seemingly innocuous changes; hence the need for expert advice in order
to know what is actually to be expected from the tests and by how much the tolerance can be
lowered (while still retaining the ability to catch erroneous changes during the code rewrite).

> BOBYQAOptimizerTest has two failing tests
> -----------------------------------------
>
>                 Key: MATH-1057
>                 URL: https://issues.apache.org/jira/browse/MATH-1057
>             Project: Commons Math
>          Issue Type: Bug
>    Affects Versions: 3.2
>         Environment: Mac OS X 10.9 and also Linux 3.4 kernel; Java 7; Maven 3.1.1
>            Reporter: Sean Owen
>            Priority: Minor
>         Attachments: MATH-1057.patch
>
>
> I see two test failures, in both the copies of BOBYQAOptimizerTest:
> {code}
> Failed tests: 
>   BOBYQAOptimizerTest.testAckley:209->doTest:282->doTest:338 expected:<0.0>
but was:<1.047765607609108E-8>
>   BOBYQAOptimizerTest.testAckley:208->doTest:281->doTest:336 expected:<0.0>
but was:<1.047765607609108E-8>
> Tests in error: 
>   BOBYQAOptimizerTest.testDiffPow:187->doTest:282->doTest:322 » TooManyEvaluations
>   BOBYQAOptimizerTest.testDiffPow:186->doTest:281->doTest:326 » TooManyEvaluations
> {code}
> (This predated the patches I've worked on so I don't think it's me!)
> I tried on Mac OS X and Linux and see the same, so don't think it is an environment issue.
I'll see if a little digging can uncover the issue from a recent commit.



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message