commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thomas Neidhart (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MATH-1057) BOBYQAOptimizerTest has two failing tests
Date Sun, 03 Nov 2013 20:24:17 GMT

    [ https://issues.apache.org/jira/browse/MATH-1057?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13812474#comment-13812474
] 

Thomas Neidhart commented on MATH-1057:
---------------------------------------

For the testDiffPow testcase, I further debugged with the two different jdks, and after iteration
2219 the objective function output changes.

The difference/error then accumulates and results that the algorithm converges much slower.
I could track down the problem to the Math implementation, most likely the sqrt or exp. Changing
all the Math calls to our own FastMath solves the problem and the test executes correctly
for all jdks.

I wonder why we use Math in the first place, as normally we eat our own dog-food and use FastMath.

btw. the problem also is existent in the 3.2 release so not at all related to your previous
patch.

> BOBYQAOptimizerTest has two failing tests
> -----------------------------------------
>
>                 Key: MATH-1057
>                 URL: https://issues.apache.org/jira/browse/MATH-1057
>             Project: Commons Math
>          Issue Type: Bug
>    Affects Versions: 3.2
>         Environment: Mac OS X 10.9 and also Linux 3.4 kernel; Java 7; Maven 3.1.1
>            Reporter: Sean Owen
>            Priority: Minor
>
> I see two test failures, in both the copies of BOBYQAOptimizerTest:
> {code}
> Failed tests: 
>   BOBYQAOptimizerTest.testAckley:209->doTest:282->doTest:338 expected:<0.0>
but was:<1.047765607609108E-8>
>   BOBYQAOptimizerTest.testAckley:208->doTest:281->doTest:336 expected:<0.0>
but was:<1.047765607609108E-8>
> Tests in error: 
>   BOBYQAOptimizerTest.testDiffPow:187->doTest:282->doTest:322 » TooManyEvaluations
>   BOBYQAOptimizerTest.testDiffPow:186->doTest:281->doTest:326 » TooManyEvaluations
> {code}
> (This predated the patches I've worked on so I don't think it's me!)
> I tried on Mac OS X and Linux and see the same, so don't think it is an environment issue.
I'll see if a little digging can uncover the issue from a recent commit.



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message