commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gilles (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MATH-1012) Reduce code duplication in "RandomDataGenerator"
Date Thu, 01 Aug 2013 13:13:49 GMT

    [ https://issues.apache.org/jira/browse/MATH-1012?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13726418#comment-13726418
] 

Gilles commented on MATH-1012:
------------------------------

"RandomGeneratorFactory" class created in revision 1509222.

                
> Reduce code duplication in "RandomDataGenerator"
> ------------------------------------------------
>
>                 Key: MATH-1012
>                 URL: https://issues.apache.org/jira/browse/MATH-1012
>             Project: Commons Math
>          Issue Type: Improvement
>    Affects Versions: 3.2
>            Reporter: Gilles
>            Assignee: Gilles
>            Priority: Trivial
>              Labels: cleanup
>             Fix For: 3.3
>
>         Attachments: MATH-1012.patch
>
>
> Some duplication exists in "o.a.c.m.random.RandomDataGenerator".
> That partly arises from having a method that requires a "o.a.c.m.random.RandomGenerator"
parameter vs a similar method but with a "java.security.SecureRandom" parameter.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message