commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Piotr Wydrych (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (MATH-940) AbstractExtendedFieldElementTest should be renamed to ExtendedFieldElementAbstractTest
Date Wed, 06 Mar 2013 10:12:14 GMT

    [ https://issues.apache.org/jira/browse/MATH-940?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13594568#comment-13594568
] 

Piotr Wydrych edited comment on MATH-940 at 3/6/13 10:12 AM:
-------------------------------------------------------------

Apply the patch. Then, rename the file src/test/java/org/apache/commons/math3/AbstractExtendedFieldElementTest.java
to src/test/java/org/apache/commons/math3/ExtendedFieldElementAbstractTest.java
                
      was (Author: wydrych):
    Apply the patch, then rename the file src/test/java/org/apache/commons/math3/AbstractExtendedFieldElementTest.java
to src/test/java/org/apache/commons/math3/ExtendedFieldElementAbstractTest.java
                  
> AbstractExtendedFieldElementTest should be renamed to ExtendedFieldElementAbstractTest
> --------------------------------------------------------------------------------------
>
>                 Key: MATH-940
>                 URL: https://issues.apache.org/jira/browse/MATH-940
>             Project: Commons Math
>          Issue Type: Bug
>            Reporter: Piotr Wydrych
>            Priority: Blocker
>         Attachments: AbstractExtendedFieldElementTest.patch
>
>
> According to build.xml, abstract tests should be placed in files **/*AbstractTest.java.
Currently (rev 1453206), building jar crashes on AbstractExtendedFieldElementTest. It should
be renamed to ExtendedFieldElementAbstractTest.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message