commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lukasz Lenart (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (OGNL-230) Update Javassist to 3.17.1
Date Thu, 17 Jan 2013 06:48:22 GMT

    [ https://issues.apache.org/jira/browse/OGNL-230?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13555919#comment-13555919
] 

Lukasz Lenart commented on OGNL-230:
------------------------------------

I've tried compile commons-ognl with the version 3.17.1-GA on JDK5 but got

[ERROR] bad class file: /Users/lukaszlenart/.m2/repository/org/javassist/javassist/3.17.1-GA/javassist-3.17.1-GA.jar(javassist/CannotCompileException.class)
[ERROR] class file has wrong version 50.0, should be 49.0

looks like the jar in the Maven Central was build with JDK6 :\ When I try to build on JDK6
many tests fail.

The only version which works is 3.16.1-GA, I had the same with OGNL 3.x (but just only on
JDK6).
                
> Update Javassist to 3.17.1
> --------------------------
>
>                 Key: OGNL-230
>                 URL: https://issues.apache.org/jira/browse/OGNL-230
>             Project: Commons OGNL
>          Issue Type: Improvement
>          Components: Core Runtime
>            Reporter: Eduardo Macarron
>            Priority: Trivial
>              Labels: javassist
>   Original Estimate: 1h
>  Remaining Estimate: 1h
>
> Hello. 
> I have just tested latest MyBatis trunk with OGNL 4 and all test pass. Good work!
> I noticed OGNL 4 depends on a quite old Javassist version (3.12.1). I would like to suggest
to upgrade to 3.17.1 (still jdk 5) before going GA.
> BTW, this version is ASL 2.0 (old versions are not)
> Note Javasisst maven groupid has changed:
> from:
>     <dependency>
>       <groupId>javassist</groupId>
>       <artifactId>javassist</artifactId>
>       <version>3.12.1-GA</version>
>     </dependency>
> to: 
>     <dependency>
>       <groupId>org.javassist</groupId>
>       <artifactId>javassist</artifactId>
>       <version>3.17.1-GA</version>
>     </dependency>

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message