commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gilles (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (MATH-894) Cleanup of "ResizableDoubleArray" ("o.a.c.m.util")
Date Wed, 14 Nov 2012 14:16:13 GMT

     [ https://issues.apache.org/jira/browse/MATH-894?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Gilles updated MATH-894:
------------------------

    Attachment: MATH-894.patch

Please have a look at the attached patch.
Instead of adding a
{code}
public double compute(UnivariateStatistic s)
{code}
in {{o.a.c.m.util.ResizeableDoubleArray}}, I think that it is better to provide a subclass
with the additional functionality. Mainly, this avoids a class in "util" to depend on another
package.
If useful beyond "DescriptiveStatistics", the subclass can be made "public".

OK to commit?

                
> Cleanup of "ResizableDoubleArray" ("o.a.c.m.util")
> --------------------------------------------------
>
>                 Key: MATH-894
>                 URL: https://issues.apache.org/jira/browse/MATH-894
>             Project: Commons Math
>          Issue Type: Improvement
>    Affects Versions: 3.0
>            Reporter: Gilles
>            Assignee: Gilles
>            Priority: Minor
>             Fix For: 3.1, 4.0
>
>         Attachments: MATH-894.patch
>
>
> Method "addElement" should not call "contract()", as it will almost always make the storage
array shrink on the first call since it will be considered "too big" (for just storing one
element).
> See discussion about this change in MATH-757.
> Miscellaneous code modifications are also proposed in order to improve encapsulation.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message