commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Phil Steitz (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MATH-894) Cleanup of "ResizableDoubleArray" ("o.a.c.m.util")
Date Wed, 14 Nov 2012 17:50:13 GMT

    [ https://issues.apache.org/jira/browse/MATH-894?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13497274#comment-13497274
] 

Phil Steitz commented on MATH-894:
----------------------------------

I had the same thought about the dependency and agree it is better not to have it.  I wonder
if there is an even better design somehow.  This is one place where the lack of array reference
semantics limits us in Java.  I am OK with the subclass solution if we can't think of anything
better.

+1 for deprecating the initialCapacity field and setter (but need to leave them in for compatibility
until 4.0)


                
> Cleanup of "ResizableDoubleArray" ("o.a.c.m.util")
> --------------------------------------------------
>
>                 Key: MATH-894
>                 URL: https://issues.apache.org/jira/browse/MATH-894
>             Project: Commons Math
>          Issue Type: Improvement
>    Affects Versions: 3.0
>            Reporter: Gilles
>            Assignee: Gilles
>            Priority: Minor
>             Fix For: 3.1, 4.0
>
>         Attachments: MATH-894.patch
>
>
> Method "addElement" should not call "contract()", as it will almost always make the storage
array shrink on the first call since it will be considered "too big" (for just storing one
element).
> See discussion about this change in MATH-757.
> Miscellaneous code modifications are also proposed in order to improve encapsulation.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message