commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gilles (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MATH-894) Cleanup of "ResizableDoubleArray" ("o.a.c.m.util")
Date Wed, 14 Nov 2012 23:12:13 GMT

    [ https://issues.apache.org/jira/browse/MATH-894?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13497575#comment-13497575
] 

Gilles commented on MATH-894:
-----------------------------

Would removing the _private_ "initialCapacity" field break compatibility?
It will break serialization but we agreed that we would not support cross-version serialization.

Similarly, would changing the name of a private field ("contractionCriteria") break compatibility?

Also could I add new "double" fields for the expansion factor and the contraction criterion
to replace the current "float" ones, or would it break compatibility?

                
> Cleanup of "ResizableDoubleArray" ("o.a.c.m.util")
> --------------------------------------------------
>
>                 Key: MATH-894
>                 URL: https://issues.apache.org/jira/browse/MATH-894
>             Project: Commons Math
>          Issue Type: Improvement
>    Affects Versions: 3.0
>            Reporter: Gilles
>            Assignee: Gilles
>            Priority: Minor
>             Fix For: 3.1, 4.0
>
>         Attachments: MATH-894.patch
>
>
> Method "addElement" should not call "contract()", as it will almost always make the storage
array shrink on the first call since it will be considered "too big" (for just storing one
element).
> See discussion about this change in MATH-757.
> Miscellaneous code modifications are also proposed in order to improve encapsulation.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message