commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Luc Maisonobe (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (MATH-890) Interval and IntervalsSet methods naming are inconsisten
Date Mon, 05 Nov 2012 08:49:11 GMT

     [ https://issues.apache.org/jira/browse/MATH-890?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Luc Maisonobe resolved MATH-890.
--------------------------------

    Resolution: Fixed

Fixed in subversion repository as of r1405711.
                
> Interval and IntervalsSet methods naming are inconsisten
> --------------------------------------------------------
>
>                 Key: MATH-890
>                 URL: https://issues.apache.org/jira/browse/MATH-890
>             Project: Commons Math
>          Issue Type: Improvement
>    Affects Versions: 3.0
>            Reporter: Luc Maisonobe
>            Assignee: Luc Maisonobe
>            Priority: Minor
>             Fix For: 3.1
>
>
> The Interval and IntervalSet in the org.apache.commons.math3.geometry.euclidean.oned
package share some features but use different names. IntervalsSet inherit some names from
its top level interface (Region) which is independent from dimension and are also consisten
with sets composed of disjoint intervals or are infinite. Interval only has names which are
meaningful for one dimension, finite intervals.
> For consistency, the specific names provided by Interval API should be replaced by the
more generic names provided by the IntervalsSet and Region API. The changes are:
> * getLower    -> getInf
> * getUpper    -> getSup
> * getLength   -> getSize
> * getMidPoint -> getBarycenter

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message