commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gilles (JIRA)" <>
Subject [jira] [Commented] (MATH-811) Improve event detection by selecting g function slope
Date Wed, 26 Sep 2012 09:16:08 GMT


Gilles commented on MATH-811:

bq. I think an enum with three choices (increasing, decreasing, both slope directions) is
less confusing.

I think that it is more confusing; especially if we speak of "slope direction" (a slope cannot
have _both_ directions).
If we really want to reduce the concept embodied in the enum to just "slope direction selection",
it should be made clear in the name, e.g.:
public enum SlopeDirectionSelector {

Then the method "getSlopeSelection" should be renamed as
  SlopeDirectionSelector getSlopeDirectionSelector();

> Improve event detection by selecting g function slope
> -----------------------------------------------------
>                 Key: MATH-811
>                 URL:
>             Project: Commons Math
>          Issue Type: Improvement
>    Affects Versions: 3.1
>            Reporter: Yannick TANGUY
>         Attachments: JIRA-811_slope_selection.patch, JIRA-811_slope_selection_with_spaces.patch
> We would like to select g function slope in CommonsMath event detection feature.
> This would improve event detection for the final user (the possibility to ignore some
events, and less computation time) and also correct a bug found while using OREKIT (see
in our applications. 
> The modification consists in adding a method (getSlopeSelection() : int) in EventHandler,
and modifying one conditionnal in the method evaluateStep (class EventState). 
> We can provide modified code and unitary tests for this feature.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see:

View raw message