commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Henri Yandell (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (LANG-794) SystemUtils.IS_OS_WINDOWS_2008, VISTA are incorrect
Date Wed, 12 Sep 2012 05:50:10 GMT

     [ https://issues.apache.org/jira/browse/LANG-794?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Henri Yandell updated LANG-794:
-------------------------------

    Fix Version/s: 3.2
    
> SystemUtils.IS_OS_WINDOWS_2008, VISTA are incorrect
> ---------------------------------------------------
>
>                 Key: LANG-794
>                 URL: https://issues.apache.org/jira/browse/LANG-794
>             Project: Commons Lang
>          Issue Type: Bug
>          Components: lang.*
>    Affects Versions: 3.1
>         Environment: Windows Server 2008 R2, Rackspace Cloud Instance
>            Reporter: Tyler Hobbs
>             Fix For: 3.2
>
>
> On Windows Server 2008 R2 (a Rackspace Cloud Instance), the values of SystemUtils.IS_OS_WINDOWS_2008
and SystemUtils.IS_OS_WINDOWS_VISTA are incorrect: the former is false and the latter is true.
> I'm not sure how to fix the VISTA flag (as I don't have an instance to test against),
but the cause of WINDOWS_2008 being set to false is that the match explicitly requires the
version to be 6.1, where 6.0 can apparently also be the version number for 2008 R2.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message