commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gilles (JIRA)" <>
Subject [jira] [Commented] (MATH-839) In "RealDistribution" implementations, rename method "cumulativeProbability(double,double)" to "probability(double,double)"
Date Sat, 04 Aug 2012 19:48:03 GMT


Gilles commented on MATH-839:

bq. we can do all the work for 3.1

No. The new method cannot be added to the {{RealDistribution}} interface as it would break
backwards compatibility.
For this reason, some unit tests also cannot be updated to not use the deprecated method (see
revision 1369420).

What can be done for 3.1, has been done:
(/) Add new method to {{AbstractRealDistribution}} and to the implementations that override
(/) Redirect deprecated method to the new method.

> In "RealDistribution" implementations, rename method "cumulativeProbability(double,double)"
to "probability(double,double)"
> ---------------------------------------------------------------------------------------------------------------------------
>                 Key: MATH-839
>                 URL:
>             Project: Commons Math
>          Issue Type: Task
>    Affects Versions: 3.0
>            Reporter: Gilles
>            Assignee: Gilles
>            Priority: Trivial
>              Labels: api-change
>             Fix For: 3.1, 4.0
> Cf.
> Cf.
> The method currently named "cumulativeProbability(double,double)" in fact provides the
_probability_ of the variable to be within the given interval. The name "probability" would
thus be more accurate (and shorter).

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


View raw message