commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gilles (JIRA)" <>
Subject [jira] [Commented] (MATH-851) Add convolution
Date Tue, 21 Aug 2012 11:35:38 GMT


Gilles commented on MATH-851:

Thanks for your interest.

I'm rather picky about the source code formatting. ;) Please have a look at the discussions
that took place in the context of other contributions:

In addition:
* Local variables must not start with an uppercase letter.
* Be careful not to use bit operators instead of logical ones.
* The exception should probably be {{NoDataException}}.
* In the test class, "10e-14" should be written as "1e-13". Please also refer to the remark
about "locality" in test methods, in one of the above references.
* Do not use LaTeX syntax in the Javadoc comments (they should be either ASCII or "readable"
* The unit tests should also cover the preconditions.

About the design:
I don't think that {{RealVector}} should be used here. The accessor ("getEntry") is likely
to be much slower than array access.
Utility (i.e "static") methods are usually collected in a class whose name ends with "...Utils"
(that would be "FilterUtils" here) with a unique "private" constructor.
A method name is preferably a verb (i.e. "convolve").
However such choices are to be discussed on the "dev" ML.

> Add convolution
> ---------------
>                 Key: MATH-851
>                 URL:
>             Project: Commons Math
>          Issue Type: New Feature
>            Reporter: Clemens Novak
>            Priority: Minor
>         Attachments:,
> I created a function performing (one-dimensional) convolution. Currently, the function
is in a class called Filter, but I am not sure whether this is the appropriate place for it(?).

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


View raw message