commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gilles (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MATH-839) In "RealDistribution" implementations, rename method "cumulativeProbability(double,double)" to "probability(double,double)"
Date Sat, 04 Aug 2012 19:28:02 GMT

    [ https://issues.apache.org/jira/browse/MATH-839?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13428664#comment-13428664
] 

Gilles commented on MATH-839:
-----------------------------

Modified {{NormalDistribution}} and {{LogNormalDistribution}} in revision 1369415.
                
> In "RealDistribution" implementations, rename method "cumulativeProbability(double,double)"
to "probability(double,double)"
> ---------------------------------------------------------------------------------------------------------------------------
>
>                 Key: MATH-839
>                 URL: https://issues.apache.org/jira/browse/MATH-839
>             Project: Commons Math
>          Issue Type: Task
>    Affects Versions: 3.0
>            Reporter: Gilles
>            Assignee: Gilles
>            Priority: Trivial
>              Labels: api-change
>             Fix For: 3.1, 4.0
>
>
> Cf. http://en.wikipedia.org/wiki/Cumulative_distribution_function
> Cf. http://en.wikipedia.org/wiki/Probability_density_function
> The method currently named "cumulativeProbability(double,double)" in fact provides the
_probability_ of the variable to be within the given interval. The name "probability" would
thus be more accurate (and shorter).

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message